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InDesign Tools
including a few you didn’t know about and a few you’ve forgotten

Kevin Slimp’s
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(Re)Mastering the 
InDesign Basics
with Kevin Slimp

1. Placing Files: Things a lot of users don’t know about placing files

PDF File (Multiple Pages)

Word & RTF FIles

TXT Files
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2. Things to know about Type

 a. Selecting fonts

 b. Adding fonts from the Adobe Library (CC version)

 c. Optical spacing, tracking & baseline shift

 d. Space before, after paragraph & First Line Indent

 e. Setting bullets, numbers and Drop Cap
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3. Object > Text Frame Options

 a. Column numbers

 b. Inset spacing

 c. Vertical justification

 d. Ignore text wrap

4. Creating tabs in InDesign

5. Getting strokes (frames) right



© 2023 Kevin Slimp • Newspaper Academy kevin@kevinslimp.com

Page 4© 2023 Kevin Slimp    kevin@kevinslimp.com Page 4

6. Getting rid of ligatures in text

7. Using the Eyedropper Tool 

8. Getting rid of that dratted circle in the middle of photos

 a. View > Extras > Hide Content Grabber

9. Scissors tool

ff   ff       

Th    Th
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10. Preferences that will help

 a. Legacy Dialog

 b. Subsetting fonts

 c. Text wrap

 d. Appearance of black

11. Options when saving files
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11. Creating Libraries

 a. Photos

 b. Text

 c. Special Effects

 d. Importance of Embedding

12. Creating the correct PDF settings for printing newspaper pages
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13. Clipping simple images in InDesign

 a. Object > Clipping Path

14. Using the Page tool

 a. The Option/Alt key is the secret ingredient

14. Using the Direct Selection Tool

 a. The “White” Arrow

15. Filling Text with a Photo

 a. Type Create Outlines
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AlignToPage

Animation Encyclopedia

BreakFrame

Points are added in middle of point segments

Mastering InDesign Scripts
Scripts Included with InDesign

AddGuides

Add Points

AdjustLayout

Align objects to a page

Run the script “Animation Encyclopedia” to automatical-
ly generate a 6-page docu-
ment that creates buttons 
with different animation 
properties. To run the script, 
go to window >utilities > 
scripts and double-click on 
Animation Encyclopedia to 
create the tutorial.

Moves content of entire pages

UnLink a text frame from others connected

Unlinks one of 
mulitple frames
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Corner Effects

Create Character Style

CropMarks

Export All Stories

FindChangeByList

When you create a character style in InDesign by basing 
the style on the selected text, InDesign records only those 
attributes that differ from the default formatting of the 
surrounding text. While this is a powerful and flexible way 
of working with character styles, it’s also different from 
the way that other applications (such as QuarkXPress and 
FrameMaker) work. In those applications, character styles 
apply every formatting attribute. The CreateCharacterStyle 
script creates a new character style based on the selected 
text and defines every formatting attribute. Not for the faint of heart. Runs a sequence of find/

change operations on the selected text. By default, it 
will change double-dashes into em-dashes.

Make a selection of 
the text you want to 
change, or you can 
change text in a story 
or document.

To find the text file that 
includes all the options 
available in this script, 
Right-Click on the
FindChangeByList 
script in the panel.

By default, the script 
changes double-dash 
to em-dash.

Great for adding centered guides to 
a pic/frame

For moving all items on all even/odd 
pages in a document.
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Path Effect

To use with text, convert text to outlines. Does not 
work with multiple lines of text

Place MultiPagePDF

SelectObjects

Image Catalog (Use Javascript Version)

MakeGrid

Neon

Creates a simple “glow” effect by dupli-
cating the selected path or paths. Each 
copy of the path is slightly smaller than 
the original, and slightly lighter. The final 
duplicate path is a white hairline. The 
resulting group of paths is something like 
an Illustrator blend.

Worthless!

nDesign can place all of the pages in a multi-page 
PDF, but it’s a manual process—you have to click the 
place icon for each PDF page you want to place. This 
script places all of the pages of a PDF on sequential 
pages, placing one PDF page per page, adding pages 
to the document if necessary as it does so.

Selects all of the objects on a spread that belong to a 
specific object type (or set of types).

 Selected Tools in 
InDesign
with Kevin Slimp

1. InDesign Scripts
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Sort Paragraphs

Alphabetize lists

Place MultiPagePDF

Similar to “Break Frame” script, except this script 
splits the links of all frames, not just the one 
selected.

Tab Utilities

FREE SCRIPTS FOR INDESIGN

1. Script Installer (by in-tools.com)

It helps you install other scripts. So meta. You should 
download it if you plan to install a lot of scripts.

2. Batch Processor

http://kasyan.ho.com.ua/batch_process_scripts/batch_
process_scripts.html

Open File - Select Object

Double Click on Batch Processor

Select Folder where you’ve copied 
the scripts you want to run

3. Price_Adjuster

Mary

John

Kevin

Wilfred

Hurley

Marx

Jethro

Gilroy

Clarise

Clarise

Gilroy

Hurley

Jethro

John

Kevin

Marx

Mary

Wilfred
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4. InGutter  (by in-tools.com)

Automatically create, customize and manage rules 
between text columns.

5. Claquos / Pie Chart Builder

6. Empty Frame Remover

7. Zoom to Width (by in-tools.com)

8. SPEEECH! (by indiscripts.com)
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9. Calendar Wizard Best free InDesign script!
Calendar Wizard
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Matt Yeager’s Auto Sales
You can trust Matt more than your mother!

865.867.5309
We lose money so you can save money!

2. Creating a Grid
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Library Elements
What goes in the library is what comes out

We’ll crop this one

Wiff with Ligatures

Wiffout without Ligs
Text with EffectsText with Effects

Here is a story that jumps from page one to page three. 
How can we make sure the jump page number is always 
right on page one? Well, it’s simple. You simply: Insert 
Special Character>Markers>Next Page Number. Here is 
a story that jumps from page one to page three. How can 
we make sure the jump page number is always right on 

Jump to page3

3. Tips for Better Libraries

Creating automated jumps
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Page Tool

TenderCare Lawn & Landscape’sTenderCare Lawn & Landscape’s

amare ramirez   |   Sr.   #3 Defensive Safety
Amare Ramirez came from San Antonio, Texas, to Derby his junior year and has been a 

part of the Panther program for just two years. 
He says one of the unique parts of the Derby football environment he has seen is the city’s 

atmosphere. “It’s a football city and I love it,” Amare said. 
He says the community supports the team even though they can’t go to the games. He 

also appreciates what the coaches do. 
“The coaches are great. They push us every day and try to make us the best men we 

can be,” he said. 
Football has given Amare the ability to see the value of hard work, dedication and to 

have a never-give-up attitude. One thing he will always remember is holding up that state 
championship trophy last year. 

“It was a great feeling and something you can never replace,” Amare said. 
He hopes his plans after high school include being able to play football at the college 

level. He plans to study dentistry and be an orthodontist upon completion of his education.

788-5416
www.tendercarelandscape.com

219 S. Water, Derby
OPEN MON-FRI 8 AM-5 PM

Panther of the Week

Days are extremely numbered for 
lawn seeding – ACT NOW

CASH AND CARRY FOR THE DO-IT-YOURSELFER
Seed • Mulch • Irrigation Parts and more

Call us TODAY...
BEFORE IT’S TOO LATE!

NOW is the time to feed trees and shrubs
You’ll get stronger and healthier trees and shrubs, making it easier for them 

to ward off weather extremes. Plus, they can flourish in the spring and be 
more likely to fight off disease or insect attacks. We can help – Call TODAY.

Freezing temperatures can damage your sprinkler system and lead to costly repairs.
Call us today to have your sprinkler system shut down and winterized before a hard freeze hits.

• Backflow Certification Available

4. Using the Page Tool

5. Using the Eyedropper

Text Here
Text like this is fancy

Stroked TextStroked Text

Eyedropper Tool
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Date/Etc/Price

Body text goes here so we can create a paragraph 
style. Body text goes here so we can create a para-
graph style. Body text goes here so we can create 
a paragraph style. Body text goes here so we can 
create a paragraph style. Body text goes here so 
we can create a paragraph style.

Headline style

Jump to page1
cutline style will go here with photo credit, etc. cutline 
style will go here with photo credit, etc.

character style for classified body

chararacter style for classified bold

6. Tips for Creating a New Template

Automated jump goes in Library

Get rid of all Type 1 fonts by January 1!
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INDESIGN

Creating a Simple Table

MFCP SAPA MACPA CPM WCP
Iowa Tennessee Pennsylvania Michigan Wisconsin

Lee Douglas Alyse Jack Janelle

236 111 188 132 204

Corn Biscuits Flapjacks Beer Cheese

Places to find things:

Align Text Vertically: Table>Cell Options>Text

Edit Strokes in/around the Table: Table>Cell Options>Strokes and Fills

Edit Column Fills (Colors): Table>Table Options>Alternating Fills

Adding Rows: Table>Insert>Rows

Adding Columns: Table>Insert>Columns

Select Entire Column (even on multiple-page table): Table>Select>Column

Merge Cells: Table>Merge Cells

Distribute Rows Evenly: Table>Distribute Rows Evenly

7. InDesign Tables

© 2021 Kevin Slimp    kevin@kevinslimp.com 9

First Name Last Name School Photos

Alica Anderson Central High School Alicia.jpg

Amanda Bracket Karns High School Amanda.jpg

Billy Chesney Central High School Billy.jpg

Candice Dickenson Central High School Candice.jpg

Daniel Druson Karns High School Daniel.jpg

Erica Ferguson Central High School Erica.jpg

Gary Frankel Karns High School Gary.jpg

Geroge Harrison Karns High School George.jpg

Gwen Hendrix Central High School Gwen.jpg

Harry Jackson Central High School Harry.jpg

Jesse Kristensen Central High School Jesse.jpg

Kendel Larrimore Karns High School Kendel.jpg

Laurie Miller Karns High School Laurie.jpg

Maddie Morrison Central High School Maddie.jpg

Rebecca Nicholson Central High School Rebecca.jpg

Samantha Oliver Karns High School Samantha.jpg

Steve Peterson Central High School Steve.jpg

Tammy Robertson Central High School Tammy.jpg

Tommy Sullivan Central High School Tommy.jpg

Editing a Placed Excel File

Importing and Creating a Table 
from Excel
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Data Merge
in InDesign

In Microsoft Excel, be sure to put a ‘ in 
front of the @ before photos ( ‘@Photos )

1. Create a database in Excel or some other application

2. Be careful to name each column heading with the name you will use in your InDesign database merge

3. If you are going to use photos in your database, be sure to title that column with a @ before the column name. In Excel,
 there must be an apostrophe before the @ symbol. Example: ‘@Photos

4. Save the database fi le as a CSV (or other database extension).

Creating the page in InDesign

5. Create a page in InDesign. In most cases, your merge will work
 best if you do this on a Master Page in the Pages panel.

6. Create column and row guides to indicate where you want
 your data to be placed on the page. Th e page on the right is set
 up with a graduation listing in mind.
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7. Window>Utilities>Data Merge

8. From the Data Merge menu, select “Select Data Source”

9. Choose the CSV (or other fi le) that was saved in your database
 application

10. Create a text frame on your page, then drag or double click on items in the 
 Data Merge panel to place them in the text frame.

11. Photos can be placed in the
 same method as text. Resize
 the photo frame inside the
 text frame using the Direct
 Selection Tool (black arrow)

12. Hit the “Return” key on your keyboard
 to select another item from the Data
 Merge panel.

After your Text Frame has all
all the information needed

13. Click on “Create Merged Document” in
 the menu

14. Select “Multiple Records” in the “Records per
 Document Page area

15. Click on “Multiple Record Layout” tab
 a. Click “Columns First”
 b. Set area between Columns to match your
  gap between columns on your page

16. Click “Options” tab
 a. Fill Frames Proportionately
 b. Center in Frame
 c. Preview Multiple Record  Layout

 d. Click on “OK” button


